07th Expansion.net
  • ホーム
  • 作品情報
  • お問合わせ
  • リンク
  • お取り扱い
  • 製作日記

■NScripterの制作者である高橋直樹さまのサイトにて、NScripterのセキュリティ問題について注意喚起がございました。

http://www.nscripter.com/201508doc.html


●起こりうる問題

外部で作成された不正なセーブデータを読み込ませることによる任意コード実行

●対策

外部から安全の保証のないセーブデータを持ち込まない

 つきましては、当サークルのゲームにおきましては「セーブデータをダウンロードする」など、外部から取得したセーブデータを使用してゲームをプレイするのは極力お控え頂けますようお願いいたします。


※ご注意ください

 NScripter公式サイトには「NScripter実行ファイルをVer3.00以上のものに差し替える」という対策も提示されているのですが、ひぐらし、うみねこなどはかなり古いバージョンのNScripterを使っているため、最新のNScripterを適用すると一部でエラーが生じる可能性がございます。
 ですので、07th Expansionとしましては、このセキュリティ問題におきましては「外部からの安全の保障のないセーブデータを持ち込まない」という対策を推奨させていただいております。

07th Expansion